Installation

Environment Requirements

Note Python version (3.5, 3.6, 3.7 or 3.8) is required for PyFlink. Please run the following command to make sure that it meets the requirements:

$ python --version
# the version printed here must be 3.5, 3.6, 3.7 or 3.8

PyFlink has already been deployed to PyPi and can be installed as following:

$ python -m pip install apache-flink

You can also build PyFlink from source by following the development guide.

Note Starting from Flink 1.11, it’s also supported to run PyFlink jobs locally on Windows and so you could develop and debug PyFlink jobs on Windows.