Installation

Environment Requirements

Note Python 3.5+ is required for PyFlink. Please run the following command to make sure that it meets the requirements:

$ python --version
# the version printed here must be 3.5+

PyFlink has already been deployed to PyPi and can be installed as following:

$ python -m pip install apache-flink

You can also build PyFlink from source by following the development guide.