环境安装

环境要求

注意 PyFlink需要特定的Python版本(3.5, 3.6 或 3.7)。请运行以下命令,以确保Python版本满足要求。

$ python --version
# the version printed here must be 3.5, 3.6 or 3.7

PyFlink已经被发布到PyPi,可以通过如下方式安装PyFlink:

$ python -m pip install apache-flink

您也可以从源码手动构建PyFlink,具体可以参见开发指南.

注意 从Flink 1.11版本开始, PyFlink作业支持在Windows系统上运行,因此您也可以在Windows上开发和调试PyFlink作业了。